Welcome Rad Power Bike owners!

Buying a Rad Power Bike? Support the forum and use my affiliate link:

Be sure to sign up for a free account to see posted images.

Note: To help support to ongoing costs of running
the site we use Amazon affiliate links.

Main Menu

RadWagon Issue - HELP - I've tried it all...

Started by pearlbeer, August 17, 2023, 09:58:06 AM

Previous topic - Next topic Support the rad owners forum


I have a 2020 RagWagon (w/ the larger wheels).
For background: The bike has 3,000mi on her. I'm a pretty good mechanic and keep my bikes in good shape. It's never been wrecked and has generally been dry and kept in a climate controlled, covered environment.

A number of months ago I rode to see Bruce Springsteen. On the way back the bike started dropping power.  (apparently, baby, I wasn't born to run). Everything works as normal, but as the power kicks in, the power seems to ramp up to the expected level and then drops completely. I can even see on the display where the wattage runs up to a few hundred watts then drops to zero.  This happens at all PAS levels and is identical when using or not using the throttle. I can get power back by turning the unit off/on.  Pedaling backwards seems to work sometimes, as well as just waiting for a bit (20-30secs?), sometimes.  However, any power recovery just sees the issue repeating itself right away.

I'll keep this post strictly to solving the mechanical problems, rather than complain about recent RAD parts and service. I just really want to get this fixed and I'm all out of options, and like Air Supply said, I'm all out of love.

Here's what I have done (in the order I recall):
- General maintenance and inspecting connections and wires (issue repeats)
- Inspect crank (issue repeats)
- Unplug and isolate brake sensor cables (issue repeats)
- Replaced fuses in battery (issue repeats)
- Borrowed a RAD battery from a friend to test the battery itself (issue repeats)
- Ordered and installed a new controller from RAD (issue repeats)
- Ordered and installed a full rear wheel assembly from RAD (issue repeats)
- Ordered and installed a battery tray from RAD (issue repeats)
- Ordered and installed new wiring harness from RAD (issue repeats)
Like I said earlier - after each 'fix', the issue is EXACTLY the same. I. have not been able to tell any difference in the problem at all. It's exactly the same issue, over and over.
At this point it seems like I've replaced everything but the LCD head unit, which would seem to me to just be a 'dumb' display rather than controlling anything?
I live in Austin TX, and there are no longer dealers on service centers locally.

Anyone have advice? I really do love this bike and want to get it running correctly again. I was able to return the wheel/motor assembly to RAD, but other than that...I've paid to replace damn near the whole damn bike and it still isn't running.

Help me're my only hope.


I think you have what's called a Rad Wagon 3. They came with 26 inch wheels.

I don't know much about issues with e-bikes but I do know, in Rad's case, the LCD display has MANY functions and controls. It's not a dumb readout kind of display. It's where the software lives that allows it to talk to the controller and it's one of the only things you haven't replaced.
I don't know if the RW3 has a separate button pad so you can choose the Pedal Assist level, turn the headlight on and off etc. The RW4 has one and it allows one to access a hidden menu. If your RW3 has one maybe change it too when/if you change the display? Sadly controllers and displays speak their own language so one needs to have compatible controller and displays. Because of the incompatibility issue if one upgrades to a different controller such as an Area 13 controller for example, it has to come with its own display.
Maybe you could borrow the display from the same person you borrowed the battery from and try it out? It might work?
I hope I've helped.


I had the exact problem but it looks like you may have ticked that box in diagnostics. 

But have you tried the borrowed battery with the replaced battery harness?  Do you see any areas burned on the connectors?  My battery was difficult to remove due to the burning. 

I lost power due to a wiring issue between the battery and harness.  I replaced the connectors on harness and battery.  They had burned.  Though the wiring looked okay the connectors were burned - melted areas and had a burn smell.  Not an electrical smell however. 

This is the part I replaced.  And it did solve my problem.  I have a Rover 5.


You mentioned that the issue happens with both PAS and the throttle, so it?s probably not the magnetic ring, but it?s worth looking at. I have over 2000 miles on my RW4 and have had to clean off the magnetic ring a couple of times. Rad support guide:

Support the rad owners forum