Welcome Rad Power Bike owners!

Buying a Rad Power Bike? Support the forum and use my affiliate link:

Be sure to sign up for a free account to see posted images.

Note: To help support to ongoing costs of running
the site we use Amazon affiliate links.

Main Menu

Radwaggon4 no throttle no go

Started by Tyler Blake, July 15, 2023, 05:32:24 AM

Previous topic - Next topic Rad E-Bike April 2024 Promotion

Tyler Blake

Hey everyone new to this forum and looking for help.

I currently just bought a rad wagon 4 (April 2023). And just like Tim the toolman Taylor I had to upgrade it! So I bought the bolton/area 13   35 amp motor controller with screen. It worked great for a long time however the PAS wasn't working at all. so Area13  sent me a whole new motor controller with screen and everything I hooked it up and the PAS still didn't work. Then I hooked up all the original stock Rad stuff to take a video to show them that the pas does in fact work with the stock components.

When I hooked everything back up to the area 13 motor controller I got a weird warning on my screen it said?Motor position sensor fault? or ?Motor controller short circuit fault!?

It started to work all of a sudden so I loaded up for a ride and when I walked it to the street I had nothing.
Right now it actually  shows no battery bars on the area 13 screen but does show 52.3 volts beside it. There's no throttle response also it doesn't even show that I have pulled the throttle which it normally does on the area 13 screen. So I hooked back up the old Rad motor controller and screen and that one says full battery but it also gives me nothing when I turn the throttle.

So with all that information do you guys think that possibly the motor could be blown? I did read on forums that the 35 amp motor controller is too powerful for the stock b Fang 500/ 750 peak motor that comes on this bike. 

Later I read I should have had the C setting on a 5 for less wattage and it was set to C10 maybe that blew the motor or is it the battery?

Never had an issues before I started swapping the controllers and screens around.

I shouldn't have touched it!! Going to a cottage In 3 weeks HELP!!

How can I diagnose what's wrong and get it fixed in time


I'm sorry I don't have a specific answer to your question, but I don't think you should lose any sleep over blowing the motor.  It's possible you have a defective motor (yay for warranty) but Altema here on the forum has intentionally tried to fry one of these motors when about to replace it with a different one, running it under full 1,600w+ power loads and high-stressed conditions and was unable to get it to fail.  Unless they suddenly redesigned it to fail somehow, that's probably not it.

Additionally, the "too powerful" controller won't just hammer the motor with full power, especially on level ground, but keep an eye on the wattage you see if you use the Bolton controller; mine usually peaks out around 700-800 unless going up a hill or heavily loaded.  IMHO, the power limit is more for safety for people who don't feel comfortable with the max power output, younger kids etc.  My Mini could literally leap out of my hands if I'm off the bike and twist full throttle accidentally, so I can understand some folks wanting to muzzle that a bit.

Hope you'll get an answer soon; Altema and DickB were very helpful when I was considering the Bolton kit for my 2021 MiniST2 - don't give up on it, that's an amazing upgrade.  I also added Bolton's hybrid mechanical-hydraulic brakes to lasso that motor; another worthy upgrade to add a bit more stopping power without having to re-plumb the entire brake system.
Shucks Ma'am, I'm no "Hero Member", I just like to wear this cape.

Tyler Blake

Hey guys just an update I did buy a replacement motor from electro bike world it's the exact befang motor replacement

I hooked it up turned it on and lo and behold I just have no battery bars on my area 13 bolt-on motor controller screen. So this leads me to believe that it's the battery??

What are you guys think thanks for all the help cheers!


Similar problems here on Radmini 4. Solved by fitting new wiring harness from controller to handlebars.