Welcome Rad Power Bike owners!

Buying a Rad Power Bike? Support the forum and use my affiliate link:

Be sure to sign up for a free account to see posted images.

Note: To help support to ongoing costs of running
the site we use Amazon affiliate links.

Main Menu


Started by Jackharrison, May 07, 2023, 12:08:41 PM

Previous topic - Next topic Rad E-Bike April 2024 Promotion


The throttle isn?t working. Any suggestions?


Quote from: Jackharrison on May 07, 2023, 12:08:41 PM
The throttle isn?t working. Any suggestions?

Just the garden variety response here, Check ALL connections, Main wiring harness, controller,  ext.


Appreciate the suggestion. I?ll go through it again.


The throttle connections appear tight. I finally heard back from Rad via email. They are back online,but phones are still down.
I just want a throttle.


Any suggestions on where to buy a replacement throttle for the Rad Rover6+?

I'm willing to buy one even though my bike is under warranty. There's no clue as to when the company will surface again.

Thanks in advance.


Try Area 13.  They may have what you are looking for.  They are very helpful and respond quickly. 


Just a note from some work I did on a 6+:  if the pedal rotation sensor wire is broken or disconnected, the throttle won't work.  I don't mean that the throttle won't work if you are not pedaling, the system just needs to see that "wiring" live in the harness.  I don't know why.  I made a "break out" harness that fit between the pedal sensor and the main harness, so that I could look at the pedal sensor with an oscilloscope (working on a different issue...without success).

I also took the right handgrip off and slid the throttle out on the handlebar to make sure there was not interference from the rear brake lever (it has a hall sensor, as does your throttle).  If in doubt, disconnect the brake lever switches and see if the throttle comes back.


When that happened to mine, the last thing I did and it worked was, at approximately the center of the handlebars there is a screw in connection on the throttle cable and I unscrewed it sprayed some CRC ELECTRONIC CLEANER screwed it back and viola it worked, Never had an issue since.
Try it, good luck.
Get something exciting between your legs, a Rad Rover!


Thanks, everyone for your suggestions. I did find a disconnect. Once it was reconnected, the throttle worked fine.

I want to look for places along the visible wiring where I can put strain reliefs in place.



Glad I could help.
Get something exciting between your legs, a Rad Rover!