Welcome Rad Power Bike owners!

Buying a Rad Power Bike? Support the forum and use my affiliate link:

Be sure to sign up for a free account to see posted images.

Note: To help support to ongoing costs of running
the site we use Amazon affiliate links.

Main Menu

No throttle or PAS

Started by mrbadexample, February 08, 2023, 11:25:51 AM

Previous topic - Next topic Rad E-Bike April 2024 Promotion


Bike turns on, battery fully charged. No throttle or PAS. NO error codes.
Performed connector check and roll back test, still nothing.
6 weeks old and has 23 miles on it.
Radrover 6 Plus


Just a guess and maybe something you should try.

The power cuts out if the brakes are applied. It is one of those circuits where if the brakes are disconnected, the bike will still move so you are not stuck somewhere.  An open switch will let the motor run. A closed switch will inhibit the motor.  Also, if the headlight or taillight is connected badly, wrong, or corroded or something, the bike won't work.

Therefore, if you electrically disconnect the brakes and headlights and tail lights, things may work.  Keep track of the connections so you know how to plug it in again.

I am no expert and I don't own your bike, it is just a thought, do at your own risk.


I had the exact same issue 2 months ago, I tried everything (checking connections, disconnecting brake motor cutoff wires). Then gave up and brought it to a shop, they replaced the wiring harness and tested it and it worked. I went to pick it up and I was broken again. They then replaced the controller and when I picked it up it worked. I have been using it for the last week with no issues and then today it just stops working again. Exactly the same thing. No idea what to do and am kinda pissed.


About a week ago I noticed my headlight and tail light had stopped working but the bike operated fine otherwise. After checking all the connectors and reading about similar problems on other owners' Radrover 6+ I contacted the Rad support people, they sent me a new controller under warranty which arrived today. When I removed the black plastic front cable cover on the front of the downtube I noticed that one of the cables (the thickest one) had a flat and chafed spot due to being pinched by the external cable cover. It looked dodgy to me, but I installed the new controller and hoped for the best.

When I had all connectors hooked up again I plugged in the battery but now the bike doesn't work at all! I think that by manipulating the damaged cable to examine it and take pictures, I must have broken one of the tiny wires inside the damaged section of the cable. When I turn the bike on now, the main display just glows dimly for an instant, then goes dark again. I reported all this to Rad support, and they're sending me a new wiring harness under warranty.

I'll report back here when I've installed the new harness, but meanwhile I'd suggest that owners with this bike carefully examine the cables all over the bike for similar pinching or chafing problems


I am also experiencing this exact same issue. and have seen similar postings with others  Makes me wonder if there are a bad batch of controllers.

I commute daily for 3 seasons and my bike just sat in my living room for the past few months. I have two Rad bikes. The RadCity 5+ with this issue and an older RadCity 3 which I also still ride and never an issue.

After turning the bike on and no error codes all cables plugged in and no battery problems the throttle and pas failed to move the motor. I am working on how to fix this issue just now.

Carol Ottenhof

I had this issue and the tech support guys suggested disconnecting the electrical line for each of the brakes in sequence. When I disconnected the left brake lever the bike worked perfectly. Support said that they would send me a new brake lever assembly. The bike is brand new...
Being a technical guy I thought about an what was going on and concluded that the lever adjustment screw under the lever must be out of adjustment. I backed off the screw 1 turn ccw and everything worked perfectly.  There is a magnetic limit switch in the lever assembly that activates when you pull the lever cutting off power to the motor. How could support not know this and why does the manual not have a caution note next to the paragraph about adjusting the brake lever position.  Better yet how does this bike ship from the factory with this condition present


I'm also having issue with power on and no PAS or throttle. Tried disconnect/ connect brake lines with no change. I then unplugged the throttle cable and when I plugged it back in the bike took off. Luckily it just hit my garage wall and I lifted up the back tire and powered it off. I (carefully) did the process again and the throttle stuck wide open again.  May just order a whole new wiring harness if available from Rad.

Sent from my SM-N970U using Tapatalk


I bought 2 brand new RadCity5s--a step thru and a high step plus. Assembled the step thru--no problems.  Assembled the high step.  No power.  The displays on the handlebars (controllers?) work.  No error codes. No power to the rear drive wheel.  Have never ridden the bike 1 block.  Took to a supposed certified repair place.  They disavow an affiliation with Rad (can never reach them).  Told me one or both controllers are probably bad.  RadCity will not respond to my email inquiries (no phone, no chat, no text).  Thoughts?  Are there replacement controllers I can purchase?


Sorry you are having the problem.  Seems like many are having the same issue.

if you want to go to the expense, yes there are upgraded controllers out. 

Try Bolton Bikes.  They might help you troubleshoot your problem and sell you want you need. They have been helpful with me in the past.

Good Luck


I am also having this same issue.  No PAS or throttle.  Battery charged cables unplugged and re-plugged, unplugged the brackes and same result.  Removed the plug for the battery, plugged in the battery and tried it again and the controller LED(on the controller) comes on solid and when I try the throttle it flashes 1 the 8 flashes.  Does anyone know what this means?  I to can't get a hold of Rad Support!  Frustrating