Welcome Rad Power Bike owners!

Buying a Rad Power Bike? Support the forum and use my affiliate link:

Be sure to sign up for a free account to see posted images.

Note: To help support to ongoing costs of running
the site we use Amazon affiliate links.

Main Menu

Symptoms of a blown 40 Amp Fuse?

Started by davidking, September 25, 2022, 05:13:35 PM

Previous topic - Next topic Rad E-Bike April 2024 Promotion


I made the mistake of keying my charge port after the 2nd bike ride. The Bike was working fine, but the Battery wouldn't charge. The Bike then conked out on me in the middle of the street, and I walked it home. It Gave me an Error 30. I disassembled and re-assembled the Bike about 8 times, every configuration, still an Error 30.

Rad Bikes is sending me a new controller, so I got to work on the battery, opened the guts and changed the 10 amp fuse...Re-coated with liquid rubber and although it was a long shot, I thought that might have worked...same Error 30

It got me thinking..maybe the 40 amp fuse is blown and that's the problem? I used the 'search' for 40 amp fuses, but not much info about the specific problems related with a blown 40a fuse.

I really want to get some biking in before Winter


If the display powers up the 40A fuse is not blown.

Does the battery charge?


yes, the battery charges, I had to go inside the guts and luckily found the 10a fuse right away, first incision. ...liquid rubbered all broken seals, taped it up and it charges perfectly now.

They're sending me a new controller, I tried everything else, was just hoping it was the fuse or the line under the battery, but it's not.

It was working fine even after I shorted the charging slot, I took it for an errand, but it conked out on the ride home. Just so disappointing...thanks for the reply.


I am not at all clear on error code 30. I have a Rad Power 5 (1 1/2 yr./400mi) that just crapped out with a code 30. I put my wife's battery in and still a code 30. Bike has crapped out since new but not with a code 30. Seems like 30 is a catch-all error code. In my case it was one connector at a time and then test. Repeating that over and over and over I finally disconnected the large connector in front of the bike...the one with the screw ring. When I unplugged/plugged the error code disappeared. I tested it with a 20 mi. ride today and so far so good. Oh, when I put the battery back in and turned the now rotates 360 degrees. Sheesh. So I have to click and try and try start..until it turns on. Not so impressed with engineering on these bikes. Oh...when I asked who was an local authorized Rad service provider they told me the name of the only authorized provider in Minneapolis...Johnny's. When I called to ask them to look at my bike they told me "That's what you get when you buy a bike over the internet". I guess I'm on my own here on in.