Welcome Rad Power Bike owners!

Buying a Rad Power Bike? Support the forum and use my affiliate link:

Be sure to sign up for a free account to see posted images.

Note: To help support to ongoing costs of running
the site we use Amazon affiliate links.

Main Menu

No PAS checked all connectors and sensors

Started by salludanger87, June 02, 2022, 03:34:49 PM

Previous topic - Next topic Rad E-Bike April 2024 Promotion


Hi all
I have a Rhino 6 plus step thru EU version

Today i tried to ride my bike after 2 weeks of gap and found that the bike has power and all but i am unable to use throttle or pas and can only ride manually.

I called Rad and they did some troubleshooting with me like remove connectors of brake and throttle and paddle sensor etc but did not resolve the issue. Paddel sensor still blinks when pedalling.
Rad thinks it is controller issue but currnetly they are short of it. So they sent lcd and remote for now to check if the problem lies there.
Can anyone help?


Hi, did you solve the problem yet? I have more or less the same problem. After a few 400 meters the pedal assist drops to zero assistant and no throttle.  The controller still displays the number and no error is displayed.
Then after a while it suddenly works again.

Very irritating.



Fyi, I also have a RadRover 6 plus EU-version. 4 months old.



I had a similar problem , the bike was a day old.. at least it gave me a code on the display. In the end the resolution was to replace the controller. It seems these parts are not very durable.... Maybe find a repair shop in your area that may be able to fix or replace the controller ?


I've got the RR5 but have had similar problems since it was new. We actually have 4 RR's. Two 5's and two step-thru's. Two of them 1xRR5 & 1 step-thru have this issue losing PAS & throttle every time they are ridden. Both have approx. 400 mi. Resolution has been to power cycle them. That seems to work until it happens again...and it does. My RR5 just crapped out 10 mi. into a trail ride with error code 30 and wouldn't correct at all. Tech support was not helpful other than to say disconnect and reconnect ALL connectors. Seems it's a catch-all error code. Oh, tech support tried to get me to purchase a controller and even quoted a price. I thought that was interesting. I didn't buy it as I wasn't going to do that until all other things were checked first. In my case it appears the large connector on the front of the bike (the one with the screw together) seemed to resolve the issue. I separated them, put them back together and retightened them. I had power again and have made one ride of 15 miles. So....time will tell. I won't be riding anywhere I can't get rescued by a car.


My wife's bike had the same issue. It turned out that the front brakes were adjusted (by the factory) to engage really early on the handle. When released, the sensor didn't always notice and thus thought the brakes were on. This didn't happen all the time, just sometimes. Intermittently. I re-adjusted the brakes so they engaged closer to the handlebar and the problem went away.
I am not sure if this is the same issue you are having but I would check this out first.


I had the PAS sensor go bad, and with it plugged in could not even use throttle.  Easy test was to unplug the PAS and see if throttle worked.  Rad had sent me a controller but that didnt help.  Thats when I found the PAS was bad.  Good Luck!