News:

Welcome Rad Power Bike owners!

Buying a Rad Power Bike? Support the forum and use my affiliate link: https://radpowerbikes.pxf.io/Wq1EzZ

Be sure to sign up for a free account to see posted images.

Note: To help support to ongoing costs of running
the site we use Amazon affiliate links.

Main Menu

Rad battery BMS replacement

Started by DickB, December 07, 2021, 12:23:04 PM

Previous topic - Next topic Rad E-Bike April 2024 Promotion

DickB

With the cells that low, I don't know if a BMS is going to allow charging. You can try trickle charging individual cell groups through the tabs. Using the Rad charger and a 1K ohm resistor would charge a cell group at about 50 mA.

inoxa

Quote from: satsujinsha on October 25, 2023, 04:31:04 AM
Since I have the new BMS I may just go ahead and replace it.  See if I can then use the charge port.

I can't find anything on bypassing BMS to charge battery pack cell groups (or individual cells) - seems like to do that I'd have to disconnect the tabs anyway.

That's what I understand to test the cells individually you have to remove them and try to charge them on a special charger.  Sorry I don't have specific videos.  I have been down several youtube trips.  When you find one then you have a hard time finding it again.

satsujinsha

Inoxa - ahhh thx gotit. Now that I understand you were suggesting to tear it down far enough to remove individual battery cells, I'm sure I can find something (with some searching).  First, Im going to try DickB's suggestion to charge at the tabs.

DickB - I ordered some parts - a female 5.5 x 2.1mm DC charging port and a 1k ohm resister.  Once that arrives I'll piece it together.  Once assembled I'll post a pic of both the charging circuit with the resister *and a pic of the tabs across which I believe I should charge.  If you'd help validate my plan at that time (before I do anything stupid) I'd be grateful.  Prolly be a cpl days.

Really cannot overstate my appreciation. Thanks again to you both!

DickB

Quote from: satsujinsha on October 26, 2023, 07:00:31 PM
Inoxa - ahhh thx gotit. Now that I understand you were suggesting to tear it down far enough to remove individual battery cells, I'm sure I can find something (with some searching).  First, Im going to try DickB's suggestion to charge at the tabs.

DickB - I ordered some parts - a female 5.5 x 2.1mm DC charging port and a 1k ohm resister.  Once that arrives I'll piece it together.  Once assembled I'll post a pic of both the charging circuit with the resister *and a pic of the tabs across which I believe I should charge.  If you'd help validate my plan at that time (before I do anything stupid) I'd be grateful.  Prolly be a cpl days.

Really cannot overstate my appreciation. Thanks again to you both!
Just be sure to get the polarity right. Monitor voltage on the individual cell groups when charging. At trickle charge it will take quite a while to charge. If you don't see an increase in voltage after 15 minutes, one or more cells in the group is likely bad. If you see an immediate jump to 3V or more, one or more cells in the group is likely bad. I would stop trickle charging at about 3V and move on to the next cell group. Accidently shorting a charged cell group will yield bad results, so take care. Take advice on this at your own risk.

satsujinsha

Sorry for the delayed update  - life keeps interfering with my goal of messin' around with this battery. I have installed the new BMS and it is a little warm (in the area highlighted in attached screenshot).  Is this something I should be concerned about?

TL;DR

I Trickle charged the cells from the tabs - they seemed to be fine - and so I installed the new BMI.  The new BMI is a bit warm still, after 12+ hours.  My initial thought was that the BMI might be balancing the batteries - so I waited ~12hrs thinking it might complete the balance and cool down.  Alas, the BMI is still warm, hence the question.


Any thoughts on why the BMI would be warm without any load and no charger plugged in?
Also, Any suggestions as to next steps?  I'm thinking I will:
1. Let it sit for another 24 hours and see if it's still warm.
2. try charging after 24 hours - see what happens.
3. test output voltage ---see if the same problem (~21 volts instead of 48) presents.


satsujinsha

....i meant to attach a .png to previous comment, but it appears I cannot delete or modify the comment.  I've attached the screenshot with a highlight outlining the warm area.