Author Topic: Received my new Radcity 5 Plus  (Read 1369 times)

rolandl

  • Newbie
  • *
  • Posts: 9
    • View Profile
Received my new Radcity 5 Plus
« on: May 20, 2023, 03:10:28 PM »
I was so excited when I saw the box sitting in my driver.

After assembly, I went to use it and no power to the motor.

Brake lights work properly, reseated all connectors I have access to with no luck in making it go.

I guess I?ll have to wait until Monday to talk with someone.

I hope my wife?s bike which is coming next week has no issue

Bobk

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Received my new Radcity 5 Plus
« Reply #1 on: May 20, 2023, 07:01:14 PM »
I had a similar problem. It was caused by a faulty break lever. There was an issue with the motor disconnect, which stops the motor when the brakes are applied. Unplug the disconnect cables one at a time then try the throttle each time you unplug. Mine was caused by the front brake lever. Rad sent me a new complete front brake assembly which was simple to replace and adjust. If it it turns out that this is the problem you can keep cycling with the faulty motor disconnect unplugged. The motor stops Asher a couple of seconds.

rolandl

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Received my new Radcity 5 Plus
« Reply #2 on: May 21, 2023, 05:42:05 AM »
This was the first thing I tried with no luck


Sent from my iPhone using Tapatalk

rolandl

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Received my new Radcity 5 Plus
« Reply #3 on: May 23, 2023, 03:06:17 AM »
Chatted with customer service yesterday,  new controller is on its way.

Getting excited again :)


Sent from my iPhone using Tapatalk

oldtexasdog

  • Newbie
  • *
  • Posts: 41
    • View Profile
Re: Received my new Radcity 5 Plus
« Reply #4 on: June 10, 2023, 12:19:28 PM »
This was the first thing I tried with no luck


Sent from my iPhone using Tapatalk

Where is the disconnect for the brake? City 5 plus the line coming out of the brake handel does not look electricial?

rolandl

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Received my new Radcity 5 Plus
« Reply #5 on: June 10, 2023, 12:23:48 PM »
This was the first thing I tried with no luck


Sent from my iPhone using Tapatalk

Where is the disconnect for the brake? City 5 plus the line coming out of the brake handel does not look electricial?
There are two lines coming out of each brake handle.  1 hydraulic and 1 electrical
 


Sent from my iPhone using Tapatalk

oldtexasdog

  • Newbie
  • *
  • Posts: 41
    • View Profile
Re: Received my new Radcity 5 Plus
« Reply #6 on: June 10, 2023, 02:36:18 PM »
Thank you rolandl!
I disconnected both one ay a time with the battery in. No difference still 21.

rolandl

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Received my new Radcity 5 Plus
« Reply #7 on: June 10, 2023, 02:37:25 PM »
Thank you rolandl!
I disconnected both one ay a time with the battery in. No difference still 21.
After receiving new controller, all is well.

Bike is excellent


Sent from my iPhone using Tapatalk

Danny59

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Received my new Radcity 5 Plus
« Reply #8 on: October 07, 2023, 02:55:33 AM »
Hello everyone,
Received new RadCity 5+ stepthru on October 5th.
Mounted everything properly and no motor power...
Trying all kind of disconnecting cables a solution found:

Power on, lights on and rear light cable disconected = motor works perfectly

But no tail/break light anymore.
Informed support of this and waiting for their answer.

Greetings, Danny, Belgium.

Danny59

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Received my new Radcity 5 Plus
« Reply #9 on: October 11, 2023, 03:16:34 AM »
Hello everyone,

Fase 2 today October 11 th......

First I had to disconnect rear light cable + light power button on to get motor power,
today this solution didn't work anymore.

Now I had to disconnect also the front left electric brake cable and motor works again.

Send already 3 mails to RAD, no answer yet....

Greetings,
Danny Belgium.

Rad Power Bikes Owners Forum

Re: Received my new Radcity 5 Plus
« Reply #9 on: October 11, 2023, 03:16:34 AM »