Author Topic: RadMini Throttle Not working correctly.  (Read 87 times)

steevwatson

  • Newbie
  • *
  • Posts: 3
    • View Profile
RadMini Throttle Not working correctly.
« on: May 21, 2020, 03:30:51 PM »
 while out today my bike has developed a problem with the throttle. When you twist it it no longer twists back when you release it. It seems to me like the spring is broken.

I've emailed Rad but judging by how busy they are I doubt I'll get a quick reply. Does anyone know of a way to fix this or is it time for a new throttle?

Sent from my Pixel 4 XL using Tapatalk


Ryan

  • Administrator
  • Sr. Member
  • *****
  • Posts: 347
    • View Profile
Re: RadMini Throttle Not working correctly.
« Reply #1 on: May 22, 2020, 12:38:34 AM »
while out today my bike has developed a problem with the throttle. When you twist it it no longer twists back when you release it. It seems to me like the spring is broken.

I've emailed Rad but judging by how busy they are I doubt I'll get a quick reply. Does anyone know of a way to fix this or is it time for a new throttle?

Sent from my Pixel 4 XL using Tapatalk

Try taking off your grips to make sure they aren't on too tight. If that's not the issue it sounds like something internal is broken. I'd take the whole throttle off and inspect before buying a new one.
Receive $50 Amazon gift card when buying a Rad Power Bike: https://www.talkable.com/x/4hUmxJ

YouTube | Instagram | EbikeEscape.com

steevwatson

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: RadMini Throttle Not working correctly.
« Reply #2 on: May 23, 2020, 09:45:11 PM »
Just an update. I took the grip and the throttle off. After working the throttle a little it did start to spring back but very slowly. The bike is still under warranty. Rad have asked me to send them a video of the problem and they will process a replacement if needed.

Sent from my Pixel 4 XL using Tapatalk


Ryan

  • Administrator
  • Sr. Member
  • *****
  • Posts: 347
    • View Profile
Re: RadMini Throttle Not working correctly.
« Reply #3 on: May 24, 2020, 02:06:27 PM »
Just an update. I took the grip and the throttle off. After working the throttle a little it did start to spring back but very slowly. The bike is still under warranty. Rad have asked me to send them a video of the problem and they will process a replacement if needed.

Sent from my Pixel 4 XL using Tapatalk

Glad to hear it's getting sorted out.
Receive $50 Amazon gift card when buying a Rad Power Bike: https://www.talkable.com/x/4hUmxJ

YouTube | Instagram | EbikeEscape.com